Course: R Language in Computational Probability and Statistics
Lecture 1: Basics of working with the R. RStudio
Lecturer: Nataliia Kruhlova
1o Take R i womy came BiH moTpideH aHAJITHKAM JaHUX?

3 nommpenHsm I1K ta qocrymy no [HTepHeTy MU cTUKaeMocs 3
HAI3BUYAIHO BEJIMKUM MOTOKOM iH(opmarii. ¥ Toi ke yac, MpeACcTaBIeHHS 1€l
iH(popMalii y 3pydIHOMY JIJIsl CIPUAHATTS opMaTi CTajao CKIATHIIINM 3aBIaHHSM.

Puc.1. 3renepoBane 300paxkeHHs 3a 3anUTOM "JIt0MHA CUIUTH 32 KOMII'TOTEPOM.
Hagxkoso mudpu Ta inpopmariis" B cucremi I Bing, Ciuens, 2024, [1]. Ixeperno: bing.com.

Ilepen kopucTyBayaMu NOCTA€ CKJIaHA 3aa4a BUOOPY MPOTPAMHOTO
3a0e3MeueHHs 1JIs1 aHaNI3y JaHUX, OCKUIbKU ICHY€ 0€3114 MPUKIaJHUX Mporpam,
10 BUKOPUCTOBYIOTHCA Y 11iH cdepi.

KPWUTEPII
BUBOPY
NMPOrPAMHOIO
3ABE3MNEYEHHA

0co6UCTI BNoAo6aHHA
KopuctyBaya

Puc. 2. Kputepii Bubopy nporpamtaoro 3adesneuyenss, https://www.canva.com/ [3]



https://www.canva.com/design/

Ha puc. 3 Bi1oOpa>keHO ekl KOMEPIiiHI TPOAYKTH JJIsI aHATI3y JaHUX.

¢

A

ICHYyIoui
N Matlab KomepLiliHi SAS &
cucremu

< s

| EXCEL Stata | J.

Puc. 3. [lesixi koMmepuiiini mporpamsi 3acobu, https://www.canva.com/ [3]

[Iporpamue cepenouine R € mpekpacHO aIbTEPHATUBOIO KOMEPIIHHIM

nporpamam, OCKUIbKH:

>
>

>

Mae 6e3KOITOBHUMN Ta BIAKPUTUN KO/I.

CepenioBuille MiICTUTh BEJIUKY KUIbKICTh IMaKETIB Ta 010J110TEK, sKi
BKJIFOYAIOTh B c€0€ MMUPOKUI CIIEKTp (PyHKIIIH 17151 00poOKH, Bizyamizalii,
aHaII3y Ta MOJICIIOBAHHS JIaHUX.

R BoJozi€ MOTY>KHUMH 1HCTPYMEHTaMU IS Bi3yaii3allii TaHuX SK,
HanpuKia, maket ggplot2, skuii 103BoJIsIE CTBOPIOBATH Bpaykarodi rpadiku
Ta JlarpaMu Jyisl IPeCTaBIECHHS PE3yJIbTATIB.

R Bimomuii cBOIM MOTY>KHUM MacHBOM CTaTUCTUYHUX METOJIB Ta
ITOPUTMIB, 1110 BKIIIOUAIOTh PETPECIHUI aHalli3, KJIACTePHUN aHai3,
aHaJi3 4acoBUX PsAJIIB Ta 0arato 1HIIOTO.

R mae Benuky Ta akTUBHY CIUIBHOTY KOPUCTYBAYiB, sIKa MOCTIHHO PO3BUBAE
HOBI TakeTH Ta QyHKIIT Ayg aHami3y gaHux. Lle 3a0e3nedye miaTpUMKyY Ta
MO>KJIMBICTh OOMIHY 3HaHHSIMH CEpeJ] CIIEIIAIICTIB 3 aHaJI3y JaHUX.

R nerko iHTErpyeThCs 3 IHIIMMU MOBaMHU ITPOTrPaMyBaHHS, TAKUMU K
Python uu Java, a Takox 3 pi3HUMHU 0a3aMH JTaHUX.

3 puc. 4 MOXHa Ji3HATUCS TIPI3BUIIA PO3POOHUKIB MOBHU IIporpaMmyBaHHs R.


https://www.canva.com/design/

PO3POBHUNKW-
BYEHI 3 HOBOI
3ENAHAIL

Puc. 4. Po3poOHukn MOBH IIporpamyBanHs, https://www.canva.com/ [3]

CrtBopeno apxiB CRAN (Comprehensive R archive network), ne 3i0paHi yci
BizioMi o(iriiini maketu R.

B [2] MoxHa 3HalTH yci HeoOX1IHI pOorpaMHi 3aco0H, OB’ sI3aHi 3
CepeIoBUILIEM MTporpamyBaHHs R, Ta 3BepHYTHCS 3 MUTAHHIMH CTOCOBHO
pO3B’A3aHHS 3a7a4.

JloMmariHs CTOpiHKa caiiTy WWW.r-project.org 3o00pakeHa Ha puc. 5:

Q The R Project for Statistical Computing

Getting Started

[Home]
R is a free software environment for statistical computing and graphics. It compiles and runs on a wide
Download variety of UNIX platforms, Windows and MacOS. To download R, please choose your preferred CRAN
CRAN mirror.
If you have questions about R like how to download and install the software, or what the license terms
R Project are, please read our answers to frequently asked questions before you send an email.
About R
Logo News
Contributors
What's New? « R version 4.3.3 (Angel Food Cake) has been released on 2024-02-29.
Reporting Bugs « Registration for useR! 2024 has opened with early bird deadline March 31 2024.
Conferences « R version 4.3.2 (Eye Holes) has been released on 2023-10-31.
Search
Get Involved: Mailing Lists « R version 4.2.3 (Shortstop Beagle) has been released on 2023-03-15.
Get Involved: Contributing « You can support the R Foundation with a renewable subscription as a supporting member.
Developer Pages
R Blog News via Mastodon

Puc. 5. Caiitr www.r-project.org

3 mpuKIIaIaMu KJIaciB 3aJ1ad Ta METO/IIB, IO Peai30BaHi B cepeoBuIi R, MmoxHa
03HaHOMUTHUCH 3 pUC. O.
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Puc. 6. Ilpukimagu kinacis 3agad, peamizoBanux B R, https://www.canva.com/ [3]

RStudio

RStudio - e inTerpoBaHe cepeIoBHUIIE PO3POOKH, SIKE JO3BOJISE MPAIIOBATH
3 MOBOIO MporpaMmyBaHHs R 3a gonomoroto rpadigdoro iHTepdeiicy. Xoua
OCHOBHA poOoTa B R BinOyBaeThCs yepes KOMaHIHUH PsIOK, HassBHICTH RStudio
3HAYHO TOJIETIy€e BUKOpUCTaHH R, ocobmBo i movatkiBiiB. RStudio Hanae
3py4yHuit iHTepdeiic Aj1s1 HanmMCaHHsS KOy, BAKOHAHHSI KOMaH I, Bi3yalizallli JaHux
Ta IHIIKUX 3aBJaHb. Ha puc. 7 300paxkeHo iHTepdelc Hboro cepeoBUIla PO3POOKH.

- o X
MaHenb meHo

@ Rrstudio

File Edit Code View Plots Session Build Debug Profile Tools Help
© .0y - AR =
e MaHenb iHCTOVMEHTIB
led12* O test7R R data sets O | Untitled11* © | Untitied 14" © | Untitled15* © | Untitled16 Rdatase M wmm Environment  History  Connections  Tutorial -0
SourceonSave A /- @Run | o Source ~ g * Import Dataset = @ 196 M - List -
1 R = 1k Global Environment ~
BikHO cKpunTis m—
|I1auenb, Lo MicTUTB icTopito | pobouunii npoctip
Files Plots Packages Help Viewer Presentation -0
»
wpt = R Search Resuits -
Console  Terminal Background Jobs -

R R421-D
*citation()' on how to cite R or R packages in publications.
Type ‘demo()' for some demos, 'help()' for on-line help, or

‘help.start()' for an HTML browser i o B
TR St W

> cos(pi/6)
[1] 0.8660254

> 72diff

st 1. packagesIQY

WAR toc required to build R packages but is not currently installed. Please download
and install the appropriate sion of R before proceeding:

ows /Rt001s,
C:/Users/HaTania/AppData/Local/R/win-1ibrary/4.2"
udio.com/bin ndows /contrib/4.2
Content type 'application/zip' Tength 155069 bytes (151 KB)
downloaded 151 k8

GFA_1.0.5.zip"

package ‘GFA' successfully unpacked and MD5 sums checked

The downloaded binary packages are in
+\Us:

C:\l caaldaTania\AppData\Local\Temp\Rtmpe67 zzM\d v - =
* |KomanaHwit pagok |

vignettes: | llaHenb 3 rpadikamm abo gonomoroto ]
diffoby_diffoty  Introduction to Diffobj HIM source R code
diffobj_embed Embed Diffs in R Markdown Or Shiny HTI source Rcode
rootSolve rootSolve  roots, gradients and steady-states in R PDE  source
Help pages:
adegenet Hstest Test differences in expected heterozygosity (Hs)
admisc_aglb  Check difference and / or (in)equality of numbers
it _bit_rangediff  bit range difference
bit_bit_setops  bit set operations
bit-merge_rev Fast functions for sorted sets of integer
bit_symdiff Symmetric set complement
bit64: .cummin.integer64 Cumulative Sums, Products, Extremes and lagged differences
broom:glance survdiff Glance at a(n) survdiff object

broom:tidy,surviff
data table:setops
dbplyrintersect 1bl_lazy
Deriy.-Deriv-package
Detiv_Deriv

Tidy a(n) survdiff object

Set operations for data tables
SQL set operations
Symbolic Differentiation
Symbolic

Controls How Lines Within a Diff Hunk Are Aligned

ofan or function

diffobj._Align Threshold-class

Puc. 7. Intepdeiic RStudio
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Koncomi RStudio BnacTuBi aesKi OIIIii, 110 HOJETIIYIOTh MPOrpaMyBaHHS Ha
R.

Hamnpukinaz, KoJin KOpUCTyBad BBOJIUTH NEBHUI HaOip CHMBOJIIB, CUCTEMA
MPOTIOHYE CBOi BapiaHTU MPOIOBKEHHS KOMAH/IH.

["apstai knaBimm Ctrl + 1 ta Ctrl + | BUKJIMKAIOTh MOMEPETHIO Ta HACTYITHY
BIIMOBITHO KOMaHy. Y Tabnumii 1 HaBeieHo ekl OMIlii MyHKTIB MEHIO.

Tab.1
Hist [TyHKT MeHI0 a00 rapsidi KJIaBilu
[Mepersin Beix HELP — >Keyboard Shortcuts Help
rapsIux KiaBill
[lepernsan rapsaunx KiaBill Code->IToTpioHMIT MyHKT MEHIO
3a/1a4i View-> [ToTpiOHMI MyHKT MEHIO
3HaWTH Ta/a00 3aMIHUTH YaCTHHY Edit -> Find and Replace (Ctrl + F)
TEKCTY
KOMEHTYBaHHS/3HATTS BUJIIITUTH ()parMeHT, HATUCHYTH ITYHKT
KOMEHTYBaHHS 3 (pparMeHTy Koty merro Comment/Uncomment Lines

KoHcouap

Kounu 3anyckaerscst R a60 RStudio, y BepxHiii 4acTHHI KOHCOJII BUBOUTHCS
1H(OopMaIris Mpo BCTAHOBIIEHY BEpCito MOBU R, IHCTPYKIIIi 1110/10 OTpUMAaHHS BiJl
CepelloBUIIA I0TTOMOTH. BIpo10BkK ceaHCy y KOHCOI BiIOOpaKaeThCst BCS
MOCIOBHICTh BUKOHAHUX KOMAaHJ Ta pe3ysibTaTiB. MoKHa 6e31ocepeIHbO
MUCaTH KOMaH/IM Ta BUKOHYBATH iX.

Bci koManau y KOHCOJI1 BBOASATHCSA IMICHsl CHMBOJTY >. Hanpukiaz, BBeemMo
cos(pi/6) i matucHemo Enter. Oapasy y KoHCcoJIi Oyjie BigoOpakaTucs pe3yibTaT:

> cos(pi/6)
[1] 0.8660254

> |



PCBYJIBTaTI/I BUKOHAHHA KOMaHJI BUBOJATHCA 663HOCCP€ILHI>O TTICIIS

THCTPYKIIi, TCJISI YOT0 Y KOHCOJI 3’ IBISIETHCA 3HAK >, 110 O3HAYAE, 0 CUCTEMaA
OYiKy€ BBEJICHHS HOBOi KOMaH/IH.

3a nonomororo komauau Open File MmoxHa 3aBaHTaXUTH CKPHIIT,

cTBOpeHuit paHinie. CKpUNTA MalOTh CTAaHAAPTHE PO3IIUPEHHS *.1.

RStudio

File Edit Code View Plots Session Build Debug Profile Tools Help

New File 4

New Project...

Open File... Ctre0
Reopen with Encoding...

Recent Files 4

Open Project...
Open Project in New Session..

Recent Projects ’
Import Dataset ’
Save Ctrl+S

Save As..

Save with Encoding...
Save Al Ctrl+Alt+S

Knit Document Ctrie Shift+K
Compile Report...

Publish...

Print...

Close Ctri+W

Close All Ctrl+Shift=W
Close All Except Current Ctrl+Alt+ Shift+W
Close Project

Quit Session... Ctrl+Q

- X
In - Addins - R project: (None)
leis* © ] andaypeiR @] Untitleds @] Untitleds Environment  History ~ Connections
+nun | = Source - > #* Import Dataset = | & List =
G nmer
Data
b1 699 obs. of 36 variables
fitl List of 14
RS
en of the Toes”
pr statistical computing
bit) Files Plots Packages Help Viewer
o
DLUTELY NO WARRANTY.
der certain conditions. R: Arithmetic Operators ~ | Find in Topic
fstribution details.
Arithmetic {base} R Documentation
y contributors.
ation and . .
tkages in publications. Arithmetic Operators
' for on-Tine help, or o
terface to help. Description
These unary and binary operators perform arithmetic on numeric or complex vectors (or ebjects which
course/.RrDatal can be coerced to them)
Usage
- x
x ¥
x -y
x5y
x /v
®y
X %y
v 5f3

Puc. 8. Po6ora 3 menro RStudio

Ha puc. 8 npointoctpoBano podoty meHto RStudio

JIns BUKOHAHHS KOMaHIU B CKpUNTI B OJIOKHOTI cepeaoBuia R moTpidHo

HATHCHYTH KJaBimy F5 micist ko)KHOI KoMaH 11, B KoHcoii — Enter, 8 RStudio -

kiaginry Run.,

o6 36epertu ckpunT, NOTPIOHO:

a) BUOpaTH CKPUIIT;

0) a00 HaTUCHYTH KJaBimry “Save SCript” Ha maHesi iHCTpyMEHTIB, a00 BUOpaTH
nyHKT MeHio “File->Save as...” (“File->Save” mis ¢aiiny, skuii Bxe 30epiranu

I1]T TIEBHOIO HA3BOIO).

Sxio komaHau y daiii po3MIIICH] Y OKpEMUX PAI0YKaX, TO MK HUMH HE
MOTPiIOHO CTABUTH HISKUX PO3AUIOBHUX 3HAKIB. KOMaHIM pO3AUIAIOTE KPAIKOKO 3

KOMOIO, SIKIIIO BOHU PO3MIIILYIOTHCSI B OJTHOMY PAJIKY.

Skimo koMaH a 3aHAITO JOBTa 1 HE BMIIIAETHCSA B OJWH PAAOK, ii MOXKHA

pPO3AUIATH Ha JeKIbKa psiyiKiB. HezaBepiena koMania mpyu nepexo/ii B IHIINAN



PSAIOK aBTOMATUYHO MPOJIOBKYETHCS Y HACTYITHOMY PSIIKY 13 CHMBOJIOM
MIPOJIOBXKEHHS +. R MOke po3Mi3HaTH, 0 KOMaH/Ia He 3aKiHYeHa, TOMY JesKi
CUHTaKCUYHI TIOMUJIKH, SK-OT BIJICYTHICTh IYKOK, MOXKYTh TIPU3BECTHU JI0 TOTO, 1110
R crnpuiiMmatume ix sk He3aKiHUCHI KOMaHIU. Y TakOMy BUNAAKy R BuBenme + Ha
MOYaTKy HACTYITHOTO psJiKa Ta nepeije y pexxum ouikyBanss. 11lo0 nepeittu y
pPEeXUM BBEJICHHS] HOBOi KOMaHI 0€3 POIOBKEHHS aHai3y MoNepeIHbO1, MOKHA
HaTUCHYTH ESC.

Bce, m1o e micis cuMBOIy # 10 KIHIIS PSIIKA, BBAXKAETHCS cepeioBuieM R
3a KOMEHTAap.

IcTopis Ta poGouwmii mpocTip 30epiraroThest y podouomMy Katajao3i mporpamMmu
(Working Directory). Ictopis mae po3mupenns *.RHistory, po6ouwuii mpocTip -
*.RData.

30epexeHHs poboyoi mam’sti: myHKT MeHro “File->Save Workspace”.
30epexeHHs icTopil: myHKT MeHto “File->Save History”.

JlizHaTHCcs poOOUMid KaTaJlor IMporpaMu MoxkHa komantoro getwd().

> getwd()
[1] "C:/Ouck/R_course"

PoGouwii karanor Moxe OyTH 3MiHEHO KoMaH 1010 Setwd(); mpu 1iboMy ILIsAX
BKa3Y€ThCS 3a JOMOMOT0I0 CMMBOITY ciiell (/) abo moaiitauii 6excierr (\\).

> setwd("D:/R_course")

JemoHcTpamii

MoskrBocTti MOBH R nemMoHcTpye Komana demo.

>demo (graphics)# JlemoncTparris makety rpadigHOro BUBOILY
>demo (persp)
>demo (image) # iHII mpUKIaIn.

Ha puc. 9 3006pakeno npukiaa rpadiqHOro 300pakeHHsl, 110 BUBOAUTHCS MPU



3aIyCKy J€MOHCTpAIlii.

Maunga Whau Volcano

500 600

300 400

100 200

100 200 300 400 500 600 700 800

X
col=terrain.colors(100)

Puc.9. Ilpuknan rpadivnoro 300pakeHHs 3renepoanoro B RStudio

['padiku BinoOpaxarThes y Bikai Graph. 11lo6 monepenniii rpadik He
BUIAJISIBCS 3 BiKHA, MOYKHA BIZIMITUTH Y BepXHbOMY MeHI0 History -> Recording.
Komnwu 3micT poGodoro katanory 30epiraetbes y ¢aitii, 3MicT rpadigHOTO

BiKHA TEX 30€PIraeThCsl.
OTpuMaHHS T10BiIKH

IcHye nekinbka cnoco0iB OTpUMATH JOTIOMOTY 3 BUKOpUCTaHHsIM R. OquH 3
HUX - IEPEUTH 10 BEPXHHOTO MeHI0 Ta BuOpaTH nusix: Help -> R functions (some
text). ITicist 1bOro BIAKPUETHCS BIKHO 3alUTY, KyJAd NOTPIOHO BBECTH 1M's
byHKIIT, 1715 SIKOT BH ITyKA€ETE JOTIOMOTY. [HIIN MOKIMBOCTI OTPUMATH JOTIOMOTY
BKJIFOYAIOTH O€3I0oCcepeIHE 3acTOCyBaHHs KoHcou. Hanpukian, iHdopmariito mpo
dbyukiito "diff" Mo)kHa 3HAWTH, BUKOHABIIIM OJIHY 3 HACTYITHUX KOMAaH]I.

2diff
> help(diff)

k110 KopucTyBau 1ykae (PyHKIII10, Ha3Ba KO MICTUTD JISIKe
CJIOBOCTIONTYYEHHSI, MOKHA BBECTH CJIOBOCIIOYUEHHS TTICIIST TBOX MUTAITBHUX
3HakiB. Hampukian,



> 2?diff

[Ticist 4oro BUBOAMTHLCA TMEpeNiK BCIX (YHKINN, 3 IMEHAMH, IO MICTSATH

nociigoBHicTh cuMBoIiB " diff”. Ha puc

RStudio micisa BUKOHAHHSA 1i€] KOMaH/IH.

. 10 HaBEeIEHO €JIEMEHT 3 BIKHA JIOIIOMOTH

Vignettes:
diffobj_diffobj  Introduction to Diffobj HTML source R code
diffobjembed Embed Diffs in R Markdown Or Shiny HIML source R code
rootSolverootSolve  roots, gradients and steady-states in R PDFE source

Help pages:

adegenet. Hs test
admisc:-agtb

bt bit_rangediff
bit:-bit_setops
bit-merge_rev
bit::symdiff
bit64:-cummin.integerG4
broom::glance.survdiff
broom:tidy.survdiff

data table setops
dbplyrintersect.tbl_lazy
Deriv: Deriv-package
Deriv:-Deriv
diffobjAlignThreshold-class

Test differences in expected heterozygosity (Hs)
Check difference and / or (in)equality of numbers
bit range difference

bit set operations

Fast functions for sorted sets of integer
Symmetric set complement

Cumulative Sums, Products, Extremes and lagged differences

Glance at a(n) survdiff object

Tidy a(n) survdiff object

Set operations for data tables

SQL set operations

Symbolic Differentiation

Symbolic differentiation of an expression or function
Controls How Lines Within a Diff Hunk Are Aligned

Puc. 10. Criucok GyHKIIii, 1110 MICTATh CHMBOJIbHY TOCTiA0BHICTS " diff",

A0O0 MOXHA TaK:

crBopeHo B RStudio

> apropos(*max")
[1] "cummax"
[6] "pmax"

max
"pmax.int"

"max.col"

"promax"  "varimax"

"mem.maxNSize

mem.maxVSize"
"which.max"

OneprxaTu 3araibHy 1H(pOpMAIIio cepeIoBUIla MOXKHA 3a JOMOMOT0K0 KOMaHIu:

> help.start()

Ha puc. 11 Bigo6paxeno intepderic RStudio micis BUKOHaHHS OCTAaHHBOT

KOMaH/1. Y BIKHI JIONOMOTH CEPEIOBHUIIA PO3POOKH BUBOJUTHCS JOMAIIIHS

cTopiHka gonomoru R.




RStudio - X
File Edit Code View Plots Session Build Debug Profile Tools Help

O -0yl Go to file/function + Addins * Bl project: (None) +
“ixed_models.R © | untitled2*® a © | Untitled3* O | rodypsiR O | Untitleds O | Untitied< Environmen it History  Connections
SourceonSave | @ A v +Run | o+ Source * d # Import Dataset * | List *
i Global Environment ~
Data
bl 699 obs. of 36 variables
fitl List of 14
1| (Top Lev R Scrip
Console  Terminal Job:
R version 3.6.1 (2019-07-05) -- "action of the Toes"
copyright () 2019 The R Foundation for statistical computing
Platform: x86_64-wB4-mingw32/x64 (64-bit) Files Plots Packages Help  Viewer
oS
R i5 free software and comes with ABSOLUTELY NO WARRANTY. =
You are welcome to redistribute it under certain conditions. The R Language ~ | Find in Topic
Type "license()' or "licence()' for distribution details. T A "N
Statistical Data Analysis
R is a collaborative project with many contributors.
Type 'contributors()’ for more information and

‘citation()’ on how to cite R or R packages in publications.

Type 'demo()’ for some demos, 'help()® for on-line help, or
*help.start()' for an HTML browser interface to help. Manuals
Type "q()' to guit R.

[workspace loaded from C:/P"PECFPe/R_course/.RDatal An Intreduction to R The R Language Definition
Writing R Extensions R Installation and Administration

> sin(pi/4) R Data Import/Export R nternals

[1] 0.7071068

> help.start()

If nothing happens, you should open
“hrep://127.0.0.1:11685/doc/htnl /Andex. html ' yourself Reference

Packages Search Engine & Keywords

Miscellaneous Material

Puc. 11. CraproBa cTopinka gomomoru R
IHakern

MHuoxuHy (QyHKIII#, sIK1 TOB’s13aHi1 CIJIBHOIO TEMATUKOIO, Ta HA0OpU JTAaHUX,
00’ €IHYIOTh Y TTakeTH (010J110TEKH).

ITix yac BcTaHOBJICHHS MpOrpaMu R fesKi 3 OCHOBHHX ITaKeTIB
3aBaHTAXYIOTHCS aBTOMATUYHO.

Sxio makert, sikuii BaM MoTpioeH, He 0yJi0 3aBaHTAXKEHO HA KOMII I0TEp, TO

HOro MOKHA BCTAHOBHUTH 3 IHTEPHET-apXiBY, BAKOPUCTOBYIOUU MYHKT TOJIOBHOTO
menro Packages->Installpackages.

Cnouatky nporpama npornoHye oOpaTu IHTEPHET-apXiB JJIsS 3aBaHTaKEHHS.
3a ymoBYaHHsM npornonyeThes BapianT 0-cloud. ITicns uporo BuGupaeThes
HeoOX1AHUM nakeT. Bei makeTu, ki mOTPiOH1 AJ1sI KOPEKTHOI poOOTH TAHOTO
MAKeTy 1 BIICYTHI Y KOMIT IOTepl, Oy1yTh TAaKOXK aBTOMATHYHO 3aBAHTAKYBATHUCh.
[Ticns iHCTANAIIT BOHU 30€pIraloThCsl y KOMIT IOTEPI, ajie MPU KOKHOMY HOBOMY
3aMyCKy IpOorpaMu Il MaKeTHu 3HOBY MOTPIOHO MiAKITIOYATH, SKIIO MU 3 HUMHU
Oynemo mpamoBaru. [linKII0OYeHHS TakeTy BUKOHY€EThes QyHKIiero library.

> library(ggplot2)

VY npukiani Mu migkirouniy naket ggplot2, skuit BAKOPUCTOBY€ETHCS IS
noOy10BU TpadiuHuX 00’ EKTIB.

>library()

L iHCTPYKIIiS HaJla€ TIEPEITiK YCIX 3aBaHTAKEHUX MTAKETIB Pa30M 3
KOPOTKHUM TIOSICHEHHSIM 1X (QYHKI[IH (B MIHIMAJIbHOMY BapiaHTi IIbOTO MEPETiKY
MOKe OyTH KIJIbKA JIECATKIB MAKeTIB). Y1 00’ €KTH, 1110 OyJIM CTBOPEH1 a00



3aBaHTAXKEHI MPOTATOM ceaHcy podoTu 3 R 1 He Oyyu BUAaNeH] crieliaibHO
KOMaH 1010, 30epiraroTbcs y pooodomy mpocrtopi. I1ix gac 3aBepmieHHs ceancy R
3aMMTYy€E, 9 MTOTPIOHO 30eperT poOoUmii MPOCTip HA AUCKY ? SIKIIO KOPUCTYBAY
MOTOKYETHCS, TO el poOOUHIA MPOCTIP BITHOBIIOETHCS HA MIOYATKY HACTYITHOTO
ceaHcy. IIpoTe BapTo KOPUCTYBATUCH IIEI0 MOXKIUBICTIO Jy’Ke 00EPEKHO,
OCKUIBKH "cTapi" 00'eKTH MOXYTh CIOTBOPUTH poOOTY R y HOBOMY ceaHci.

3a momomororo Help-> R help->Packages BuBouThcs nepenik OCHOBHUX
MaKeTiB 3a ajadaBiTOM.

Help -> R help -> Task Views Bigo0OpakaeThbcst iHpoOpMaIlis mpo
KJ1acudiKaIlio MakeTiB M0 BIIHOIIECHHIO J0 TUITY 3aBAaHHA. [lami ciaiaye nepemik
TeM 3 IMEHaMH TaKeTiB JiJIs1 poOOTH 3 BIMOBIIHUMH 3a/1auaMH.

Mo>kHa aHaJIOT14HI1 JIii BUKOHATH Y KOHCOJII.

> available.packages()#mepenik JOCTYIHHX ITAKETIB.

>length (available.packages())# BHBOIUTBCS KIJIBKICTh TAKETIB Ha CEpBEPI.
>install.packages ("packagel”, "package2")# Bka3aHi makeTH 3aBaHTaKATHCA 1
BCTaHOBJIATHCS HA KOMII'TOTEPI.

> data() # criricox HaOOPIB JAHUX, MIAKITIOUEHHUX JI0 NUIIXY MOIIYKY.

>install.packages ("package”,dependensies=T)#Bka3aHuii makeT 3aBaHTAKUTHCS
3 IOBHUM HaOOPOM MaKeTiB, sIKi HEOOX1JIHI JIJI1 KOPEKTHOT pOOOTH JaHOTO
MaKeTy;

>search()# criucok makeTiB, MPUKPILICHUX JI0 NUIIXY MOIIYKY.

>library (help="ggplot2")# indopmaris npo maker ggplot2: cnmcok yHKIiH, 1110
MICTATBCS Y BKQ3aHOMY CTaTUCTUYHOMY ITaKeTi, aBTOPHU, HA3Ba, Bepcis R, sika
MOJKE MPAIFOBATH 3 I[UM MTaKETOM.
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