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VISUAL COMMUNICATION 

WEEK 11 

Creating Publications using Adobe InDesign, Illustrator and Photoshop 

 

Introduction to Creating Publications using Adobe InDesign, Illustrator and 

Photoshop 

According to Stubblefield (2016), there are so many things to learn and explore using Adobe 

InDesign, Illustrator and Photoshop. Each program has a robust toolset allowing artists and 

designers to create the imagery we all see on a daily basis. Photoshop has excellent photography 

and effects editing tools. Illustrator is perfect for creating logos and other line based art. InDesign 

uses comprehensive layout tools to convey messages that last a lifetime. These three programs 

work together to propel our creative future. 

According to Escudeiro, and Priester, (2017) InDesign is the best choice to design and publish 

multipage documents containing text, vector artwork, and images. Use precise grids and guides to 

position page elements and create polished layouts. Take advantage of professional typesetting 

features to format text consistently across pages, chapters, and publications. You can also publish 

your document online and share it with a single click. Use InDesign to create a variety of digital 

and printed material such as stationery, resumes, pamphlets, annual reports, catalogs, interactive 

digital publications, EPUBs, books, magazines, and more.  

InDesign excels in combining all your artwork to create a fantastic looking page layout. You see 

layouts created in InDesign on a daily basis. Newspapers, books, magazines, flyers, newsletters, 

digital publications, and even greeting cards are all created using InDesign. At this point, you’re 

probably thinking, “Can’t I just create all those things in Photoshop or Illustrator?”. The answer 

is: yes, you absolutely can create all those things using Photoshop and Illustrator. The benefit of 

using InDesign is that this program was designed for layout, and it does a much better and more 

professional job of creating layouts (Stubblefield, 2016). 

Learning Outcomes   

 At end of this week lesson the students should be able to: 

1. Explore the basics of creating publications using computer software.  

2. Plan and Layout in Adobe InDesign, and Illustrator 

3.         Creating Publications using Adobe Photoshop  

4.         Practically combine InDesign, Illustrator and Photoshop to create a publication 
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Creating publications using Adobe InDesign, Illustrator, and Photoshop involves leveraging the 

strengths of each program to produce a professional and visually appealing final product. Here's a 

step-by-step guide on how to effectively use these tools in tandem: 

1. Planning and Layout in Adobe InDesign 

InDesign is a powerful layout and page design software perfect for creating publications such as 

magazines, brochures, books, and more. 

 Project Setup: 

 Start by creating a new document in InDesign. Set the appropriate page size, 

margins, and bleed settings. 

 Define a master page to maintain consistency across your publication. This is where 

you set up common elements like headers, footers, and page numbers. 

 Layout Design: 

 Use InDesign’s grid and guide features to structure your pages. 

 Create text frames and image frames where your content will go. 

 Typography: 

 Utilize InDesign’s robust typography tools to format your text. Set up paragraph 

and character styles for consistency. 

 Ensure proper hyphenation and justification settings for professional-looking text 

blocks. 

2. Creating and Editing Graphics in Adobe Illustrator 

Illustrator is ideal for creating vector graphics that can be scaled without losing quality. 

 Designing Vector Elements: 

 Design logos, icons, infographics, and other vector elements in Illustrator. 

 Use the Pen tool, Shape tools, and Pathfinder to create complex vector shapes. 

 Working with Colors: 

 Utilize color palettes and swatches to ensure color consistency across your 

publication. 
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 Export these elements in formats compatible with InDesign (e.g., .AI, .EPS, or 

.SVG). 

3. Image Editing in Adobe Photoshop 

Photoshop is best for editing and manipulating raster images. 

 Image Editing: 

 Edit photos, adjust levels, apply filters, and perform retouching in Photoshop. 

 Ensure your images are at the appropriate resolution (300 dpi for print) and color 

mode (CMYK for print publications). 

 Creating Graphics: 

 Create backgrounds, textures, and other raster graphics. 

 Save images in appropriate formats such as .PSD, .TIFF, or .JPEG for high-quality 

print output. 

4. Integrating Elements in InDesign 

 Placing Graphics: 

 Import your vector graphics from Illustrator and raster images from Photoshop into 

InDesign. Use the “Place” command (File > Place) to insert these elements. 

 Ensure that linked files are organized and accessible to maintain the integrity of 

your InDesign document. 

 Arranging Content: 

 Position your text and images according to your layout plan. Use layers to manage 

different elements effectively. 

 Adjust the wrapping options to ensure text flows around images appropriately. 

5. Finalizing and Exporting the Publication 

 Preflight Check: 

 Use InDesign’s Preflight feature to check for potential issues like missing fonts, 

linked file errors, and overset text. 

 Correct any issues identified to ensure your document is print-ready. 

 Export Settings: 
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 Export your document as a PDF for printing. Use the Adobe PDF (Print) preset and 

ensure settings are adjusted for high-quality print output. 

 Embed fonts and include bleed and crop marks if required by your printer. 

 Packaging Files: 

 Package your InDesign document to include all linked files and fonts. This ensures 

that anyone working with your file has access to all necessary assets. 

Steps to creating Publications using Adobe InDesign  

Creating publications using Adobe InDesign involves several detailed steps, from setting up your 

document to finalizing it for print or digital distribution. Here’s a comprehensive guide to help you 

through the process: 

Step 1: Define the Project Scope 

 Determine the Purpose: Understand the type of publication you’re creating (e.g., 

magazine, brochure, book). 

 Audience and Goals: Identify your target audience and the key objectives of your 

publication. 

Step 2: Setup Your Document 

 Launch InDesign: Open Adobe InDesign. 

 New Document: Go to File > New > Document. 

 Set your page size (e.g., A4, Letter). 

 Define the orientation (portrait or landscape). 

 Set margins and bleeds. Bleeds are typically 0.125 inches (3 mm) beyond the page 

edges to ensure color runs to the edge of the page when trimmed. 

 Number of Pages: Specify the total number of pages you’ll need. 

Step 3: Master Pages 

 Create Master Pages: Go to the Pages panel, double-click on the A-Master. 

 Design your master page with elements that should appear on multiple pages (e.g., 

headers, footers, page numbers). 

 Use text frames and image frames to create placeholders. 
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 Apply the master page to other pages by dragging it from the Pages panel onto the 

target pages. 

Step 4: Layout Design 

 Grids and Guides: Set up grids and guides to help align your content. 

 Use Layout > Create Guides to establish a consistent grid structure. 

 Layers: Create different layers for text, images, and background elements for better 

organization. 

Step 5: Import Text 

 Text Frames: Use the Type tool (T) to draw text frames where your text will go. 

 Import Text: Go to File > Place and select your text files (e.g., .txt, .docx). 

 Use the “Place” cursor to click inside text frames. 

 Flow text across multiple pages by clicking the outport of one text frame and then 

clicking in another frame. 

Step 6: Typography 

 Paragraph and Character Styles: Define and apply paragraph styles for headings, body 

text, captions, etc. 

 Go to Window > Styles > Paragraph Styles or Character Styles. 

 Formatting Text: Adjust font, size, leading, kerning, and alignment. 

 Hyphenation and Justification: Set hyphenation and justification options to control how 

text flows. 

Step 7: Import Graphics 

 Image Frames: Use the Rectangle Frame tool (F) to create placeholders for images. 

 Place Images: Go to File > Place, select your image files (e.g., .JPEG, .PNG, .TIFF), and 

click to place them in the frames. 

 Adjust the frame fitting options via Object > Fitting. 

Step 8: Design Elements 

 Shapes and Lines: Use the Shape tools to create design elements such as borders, dividers, 

and background shapes. 
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 Colors and Swatches: Define your color palette using the Swatches panel. 

 Add CMYK or RGB colors depending on your output (print or digital). 

Step 9: Interactive Elements (for Digital Publications) 

 Buttons and Forms: Add interactive buttons and forms via Window > Interactive. 

 Hyperlinks: Insert hyperlinks for navigation or external links using the Hyperlinks panel. 

Step 10: Review and Proof 

 Preflight Check: Use InDesign’s Preflight panel to identify potential issues (e.g., missing 

fonts, overset text). 

 Go to Window > Output > Preflight. 

 Proofread: Thoroughly proofread your content for errors. 

Step 11: Finalize and Export 

 Package the Document: Collect all files used in the document (fonts, images) via File > 

Package. This ensures that all necessary assets are included. 

 Export to PDF: Go to File > Export, choose Adobe PDF (Print) or Adobe PDF 

(Interactive) based on your needs. 

 Set the appropriate PDF settings, including bleed and crop marks if required for 

print. 

 Export Other Formats: For digital publications, you may also export to EPUB, HTML, 

or other formats. 

Step 12: Printing or Digital Distribution 

 Print Setup: Send the packaged InDesign file or exported PDF to your printer. 

 Digital Publishing: Upload the PDF or digital format to your website, email it to your 

audience, or distribute it through digital publishing platforms. 

By following these steps, you can efficiently create a high-quality publication using Adobe 

InDesign, ensuring a professional result whether for print or digital media. 

Steps to creating Publications using Adobe Illustrator 

According to Escudeiro, and Priester, (2017), Illustrator lets you create precise, editable vector 

graphics that stay sharp when scaled to any size. Use flexible shape and drawing tools to create 
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logos, icons, and other illustrations that look equally good on a business card, flyer, or billboard. 

Edit and customize text in many ways to create striking typography. Use Illustrator to create 

artwork that will be used across different mediums, and for varied types of artwork including 

custom typography, infographics, and one-page design layouts like a form or a flyer. A vector is a 

quantity that has magnitude and direction and that is commonly represented by a directed line 

segment whose length represents the magnitude and whose orientation in space represents the 

direction. I know that definition sounded extremely complicated, but the basic idea is that vector 

graphics use mathematical calculations to create art (Stubblefield, 2016). 

Creating publications using Adobe Illustrator involves designing and arranging elements such as 

text, images, and graphics to produce visually appealing documents like brochures, flyers, posters, 

and reports. While Illustrator is primarily a vector graphics editor, it has robust features that can 

handle complex layouts for single-page and multi-page publications. Here are the steps to create a 

publication using Adobe Illustrator: 

Step 1: Project Planning 

 Define Purpose and Audience: Understand the goal of your publication and the target 

audience. 

 Collect Assets: Gather all necessary text content, images, logos, and other graphical 

elements. 

Step 2: Setup Your Document 

 New Document: Open Illustrator and go to File > New to create a new document. 

 Set the appropriate dimensions (e.g., A4, Letter, custom size). 

 Define the orientation (portrait or landscape). 

 Set the number of artboards if your publication has multiple pages. 

 Add bleed settings if your design will be printed and needs color to extend to the 

edge. 

Step 3: Setup Guides and Grids 

 Rulers and Guides: Enable rulers (View > Rulers > Show Rulers) and drag guides from 

the rulers to help align your content. 

 Grids: Use grids to ensure alignment and consistency (View > Show Grid). 

Step 4: Create Master Elements 
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 Master Templates: If your publication includes multiple pages with repetitive elements 

(e.g., headers, footers, page numbers), create a master template. 

 Design elements that will be consistent across pages. 

 Copy and paste these elements onto each artboard as needed. 

Step 5: Layout Design 

 Text Frames: Use the Type tool (T) to create text boxes. Click and drag to draw text frames 

where your text will go. 

 Place Text: Import text content by copying from your source document and pasting it into 

Illustrator, or by using File > Place to import text files. 

Step 6: Typography 

 Text Formatting: Adjust font, size, leading, kerning, and alignment using the Character 

and Paragraph panels (Window > Type > Character and Window > Type > Paragraph). 

 Paragraph Styles: Create and apply paragraph styles for headings, body text, captions, 

etc., for consistent formatting across the publication (Window > Type > Paragraph 

Styles). 

Step 7: Import and Arrange Graphics 

 Place Images: Go to File > Place to import images. Position and resize them within your 

layout. 

 Use the Selection tool (V) to move and scale images. 

 Right-click on images and select Arrange > Send to Back or Bring to Front to 

layer elements. 

Step 8: Design Graphics 

 Create Vector Graphics: Use the Pen tool (P), Shape tools (Rectangle, Ellipse, etc.), and 

the Pathfinder panel (Window > Pathfinder) to create custom vector graphics. 

 Apply Colors: Define your color palette using the Swatches panel (Window > Swatches). 

Ensure color consistency across your design. 

Step 9: Add Effects and Styles 

 Effects: Apply effects such as shadows, glows, and gradients to enhance your design 

(Effect > Stylize or Effect > Illustrator Effects). 
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 Appearance Panel: Use the Appearance panel (Window > Appearance) to manage 

multiple effects and styles on single objects. 

Step 10: Proof and Review 

 Spell Check: Use Illustrator's spell check feature (Edit > Check Spelling) to catch any 

typos or errors in your text. 

 Review Design: Zoom in and out to check details and overall layout. Ensure all elements 

are aligned properly. 

Step 11: Finalize the Document 

 Save: Save your Illustrator file (.AI) to preserve layers and editability (File > Save). 

 Package Files: Collect all linked files (images, fonts) by using the Package feature (File > 

Package). This ensures all necessary assets are included for printing or sharing. 

Step 12: Export for Print or Digital Distribution 

 Export to PDF: For print, export your document as a PDF. Go to File > Save As or File 

> Export and choose Adobe PDF. 

 Adjust settings for high-quality print output, including bleed and crop marks if 

necessary. 

 Export to Other Formats: For digital distribution, you can also export to formats like 

PNG, JPEG, or SVG. 

Step 13: Printing or Distribution 

 Print Setup: Send the PDF or packaged Illustrator files to your printer with specific 

instructions regarding paper type, finishes, and other details. 

 Digital Distribution: Upload the exported digital files to your website, email them to your 

audience, or distribute through other digital channels. 

By following these steps, you can create high-quality publications using Adobe Illustrator. Its 

powerful vector tools and flexible layout capabilities make it suitable for a wide range of 

publication types, from simple flyers to detailed reports. 

Steps to creating Publications using Adobe Photoshop 

According to Escudeiro, and Priester, (2017), Photoshop is your go-to application for working 

with pixel-based images designed for print, web, and mobile apps. Powerful editing tools let you 

correct exposure and color balance, crop and straighten images, alter colors in your photograph, 
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remove blemishes from a portrait, or combine multiple images into a new scene. Pixels are units 

of measurement that appear as dots or squares on a screen. Each pixel is used to make up the 

images that we see on our computer monitors, mobile phones, televisions etc. The images from 

digital cameras are the most common pixel based images. The most important attribute of pixel 

based art is that it cannot be resized without creating distortion (Stubblefield, 2016). 

Use Photoshop to create image-heavy flyers, posters, web and app designs, videos, and animations, 

or to edit 3D content. Creating publications using Adobe Photoshop, while not its primary use 

case, is possible and can be effective for certain types of projects such as single-page flyers, 

posters, or image-heavy brochures. Photoshop is particularly useful when the publication involves 

intricate image editing and complex graphics. Here’s a step-by-step guide to creating publications 

using Adobe Photoshop: 

Step 1: Project Planning 

 Define Purpose and Audience: Understand the goal of your publication and who it is 

intended for. 

 Gather Assets: Collect all necessary text content, images, logos, and other graphical 

elements. 

Step 2: Setup Your Document 

 New Document: Open Photoshop and go to File > New. 

 Set the appropriate dimensions for your publication (e.g., A4, Letter, custom size). 

 Define the resolution (300 dpi for print). 

 Choose the color mode (CMYK for print, RGB for digital). 

 Set bleed settings if needed (add extra space around your document to allow for 

trimming). 

Step 3: Guides and Grids 

 Rulers and Guides: Enable rulers (View > Rulers) and drag guides from the rulers to help 

align your content. 

 Grids: Use grids for precise alignment (View > Show > Grid). 

Step 4: Create Layout Structure 

 Layers: Organize your document using layers for different elements (e.g., background, 

images, text). 
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 Artboards: For multi-page documents, use artboards (File > New > Artboard or Layer 

> New > Artboard). Each artboard represents a different page. 

Step 5: Add Backgrounds and Graphics 

 Background: Create a background layer. Use solid colors, gradients, or images. 

 Graphics: Import and arrange graphics and images. Use File > Place Embedded to import 

images. 

 Use the Move tool (V) to position and scale images. 

 Apply layer styles (e.g., shadows, glows) via the Layers panel to enhance graphics. 

Step 6: Add and Format Text 

 Text Tool: Use the Type tool (T) to add text. 

 Click and drag to create text boxes. 

 Enter your text content. 

 Text Formatting: Format your text using the Character and Paragraph panels (Window > 

Character and Window > Paragraph). 

 Adjust font, size, leading, kerning, and alignment. 

 Text Effects: Apply effects such as drop shadows or strokes via the Layers panel (Layer 

> Layer Style). 

Step 7: Advanced Image Editing 

 Image Adjustments: Enhance your images using adjustment layers (Layer > New 

Adjustment Layer). 

 Adjust brightness, contrast, levels, curves, hue/saturation, etc. 

 Retouching: Use tools like the Clone Stamp (S), Healing Brush (J), and Patch tool (J) to 

retouch and refine images. 

Step 8: Design Elements 

 Shapes and Lines: Use the Shape tools to create design elements such as borders and 

dividers. 

 Customize shapes using the Properties panel. 
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 Smart Objects: Convert layers to Smart Objects (Layer > Smart Objects > Convert to 

Smart Object) for non-destructive editing. 

Step 9: Proof and Review 

 Zoom and Check Details: Zoom in and out to check the details and overall layout. 

 Spell Check: Use Photoshop's spell check feature (Edit > Check Spelling) to catch any 

text errors. 

Step 10: Finalize the Document 

 Save PSD: Save your work as a PSD file to preserve layers and editability (File > Save 

As). 

 Flatten and Save Copy: For final output, flatten the image if necessary (Layer > Flatten 

Image) and save a copy in the desired format. 

Step 11: Export for Print or Digital Distribution 

 Export to PDF: For print, export your document as a PDF. Go to File > Save As and 

choose PDF. 

 Ensure high-quality print settings, including setting the resolution to 300 dpi and 

including bleed and crop marks if necessary. 

 Export for Web: For digital distribution, export in appropriate formats like JPEG or PNG 

(File > Export > Export As). 

 Optimize the resolution and file size for web use. 

Step 12: Printing or Distribution 

 Print Setup: Send the PDF or high-resolution image files to your printer. Provide specific 

instructions regarding paper type, finishes, and other details. 

 Digital Distribution: Upload the exported digital files to your website, share via email, or 

distribute through other digital channels. 

By following these steps, you can effectively use Adobe Photoshop to create visually compelling 

publications. While Photoshop is not traditionally used for multi-page layout designs, it excels in 

creating richly detailed, image-heavy publications where advanced photo editing and graphic 

design are required. 
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Further Reading 

      Suggested materials to be read by the Learner 

Navigating Creative Tools: When to Use Adobe Illustrator vs Photoshop vs InDesign 

The Adobe Trinity—Illustrator, Photoshop, and InDesign—stands as the beacon of design 

software, each with its distinct role in the crafting process. Illustrator’s prowess lies in 

vector graphics and illustrations, perfect for designs that need to scale across mediums 

without compromising quality. 

Photoshop, the digital artist’s canvas, excels in image editing and manipulation, offering 

pixel-perfect precision for every photographic masterpiece. InDesign, the maestro of layout 

and publishing, orchestrates elements on a page with an ease that makes complex designs 

look effortless. Together, these tools form the cornerstone of a designer’s workflow, but 

their true power is unleashed when used in harmony. 

Selecting the Right Tool for Your Project 

Facing the canvas of your next project, the question arises: which Adobe tool will serve 

you best? The choice hinges on the task at hand, and knowing the strengths of each program 

is key to making an informed decision. 

For vector-based tasks like logo design and brand identity, Illustrator’s precision and 

scalability are unparalleled. Photoshop should be your ally when intricate photo editing 

and digital painting are the order of the day, thanks to its layer manipulation prowess. 

When your project’s heartbeat is the rhythm of layouts and typesetting for publications, 

turn to InDesign for its superior design capabilities. Selecting the right tool not only ensures 

optimal results but also streamlines your creative process, allowing you to focus on 

bringing your vision to life. 

Graphic Design and Branding 
In the dance of graphic design and branding, Adobe Illustrator leads with grace and power. 

Its digital design toolset is primed for crafting logos, icons, and graphics that demand 

attention. Illustrator’s intuitive controls and custom brushes, along with its extensive color 

libraries, are the palette with which brand identities are painted, resonating with audiences 

across various platforms. 

When it comes to logos, Illustrator’s ability to create crisp, scalable vector art guarantees 

that your brand’s first impression is both memorable and adaptable to any format. For 

branding materials that speak the language of professionalism and creativity, from business 

cards to posters, Illustrator’s vector art ensures your message is seen loud and clear. 

Photo Retouching and Digital Art 
When a photograph’s potential is unlocked, or a digital canvas calls for a brushstroke of 

genius, Adobe Photoshop steps into the spotlight. Revered for its photo retouching 

capabilities, Photoshop allows artists to delve into the minutiae of an image, transforming 

the ordinary into the extraordinary. The ability to construct collages and combine images 

into a seamless whole exemplifies the creative latitude that Photoshop affords. 

Its sophisticated editing tools cater to detailed pixel-level adjustments, making it the ideal 

choice for tasks such as blemish retouching or color balance fine-tuning. For digital artists, 

Photoshop’s array of brushes and blending options opens a realm of possibilities, enabling 

the creation of digital art that transcends the traditional. 
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Print and Digital Publication Design 

When orchestrating the elements of print and digital publication design, Adobe InDesign 

conducts with precision and flair. As a publishing powerhouse, InDesign specializes in 

marrying typography with imagery, and crafting layouts that resonate, whether they grace 

the pages of a magazine or the screen of a tablet. The application’s ability to handle multi-

page document flows is essential when tackling complex documents like catalogs and 

comprehensive articles. InDesign’s advanced tools extend to the realm of interactive PDFs, 

where elements such as hyperlinks and animations elevate the reader’s experience. 

With superior typography tools at your disposal, InDesign ensures that your text is not just 

legible but also visually compelling, maintaining the integrity of your design vision. When 

collaboration is key, InDesign’s integration with Adobe Creative Cloud streamlines the 

production process, making it a dynamic tool for team-based projects. 

Importing and Exporting Between Programs 

The art of design often requires a chorus of applications, each playing its part. Adobe’s 

ecosystem facilitates a seamless exchange of files and assets between applications, thereby 

optimizing the creative workflow. InDesign’s capability to import Illustrator’s native .ai 

vector graphics and allow for direct edits within either program exemplifies this synergy, 

offering flexibility whether you’re dealing with a single artboard or multiple. 

Moreover, Illustrator graphics saved as layered PDFs can be finely tuned within InDesign, 

providing the power to adjust layer visibility for various illustration variations. When 

Photoshop enters the mix, its files imported into InDesign retain their color profiles and 

text wrapping options, thanks to paths, masks, or alpha channels, demonstrating the 

thoughtful integration of Adobe’s software arsenal. This interoperability not only enhances 

control over content but also streamlines the transition between creative stages. 

 

Source: Castillo, Kristine Guia (May 2009). Navigating Creative Tools: When to Use 

Adobe Illustrator vs Photoshop vs InDesign https://nexacu.com/sg/insights-

blog/navigating-creative-tools-when-to-use-adobe-illustrator-vs-photoshop-vs-indesign/ 

 

Summary 

    

By effectively using Adobe InDesign, Illustrator, and Photoshop together, you can create 

sophisticated and polished publications. InDesign serves as the hub for layout and text 

management, Illustrator provides precise vector graphics, and Photoshop handles detailed 

image editing. Mastering the integration of these tools will enable you to produce high-

quality print materials with professional results. 

Illustrations and drawings play a vital role in graphic design, offering a creative and 

versatile means of visual expression. Whether used to communicate ideas, reinforce 

brand identity, evoke emotions, or enhance visual appeal, illustrations enrich the design 

process and contribute to creating memorable and impactful designs. 
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photography plays a multifaceted and essential role in graphic design, serving as a 

powerful tool for visual communication, brand identity, emotional storytelling, and 

aesthetic appeal. By harnessing the creative potential of photography, graphic designers 

can create compelling and impactful designs that resonate with audiences and leave a 

lasting impression. The many tools available in image editing software, providing users 

with the flexibility and control to edit and manipulate digital images to their desired 

specifications. 

 

 

REFERENCES 

Castillo, Kristine Guia (May 2009). Navigating Creative Tools: When to Use Adobe Illustrator 

vs Photoshop vs InDesign https://nexacu.com/sg/insights-blog/navigating-creative-tools-when-

to-use-adobe-illustrator-vs-photoshop-vs-indesign/ Retrieved on 3rd June 2024. 

Escudeiro, Daniel and Priester, Adam (May 17, 2017) Choosing the right design app 

https://helpx.adobe.com/creative-cloud/how-to/photoshop-illustrator-indesign-overview.html 

Retrieved on 3rd June 2024. 

Stubblefield, Eryn (June 1, 2016) A Brief Overview of Photoshop, Illustrator, and InDesign 

https://www.freepik.com/blog/a-brief-overview-of-photoshop-illustrator-and-indesign/ Retrieved 

on 3rd June 2024. 

Key Books References 

Anton, Kelly Kordes & Dejarld, Tina (2019), Adobe Indesign CC Classroom in a 

Book® 2019 release. The official training workbook from Adobe. 

Faulkner, Andrew & Chavez, Conrad (2018), Adobe Photoshop CC Classroom in a 

Book® 2018 release. The official training workbook from Adobe. 

Wood, Brian (2015), Adobe® Illustrator® CC Classroom in a Book® (2015 release), Adobe. 

 

https://nexacu.com/sg/insights-blog/navigating-creative-tools-when-to-use-adobe-illustrator-vs-photoshop-vs-indesign/
https://nexacu.com/sg/insights-blog/navigating-creative-tools-when-to-use-adobe-illustrator-vs-photoshop-vs-indesign/
https://helpx.adobe.com/creative-cloud/how-to/photoshop-illustrator-indesign-overview.html
https://www.freepik.com/blog/a-brief-overview-of-photoshop-illustrator-and-indesign/

