
preencoded.png

Computer Graphics 
and Design
Lecture 5
Photoshop Interface and Tools
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Lecture learning outcomes

• Navigate the Interface: Understand and identify key components of the 

Photoshop interface, including the toolbar, options bar, and panels.

• Utilize Basic Tools: Demonstrate proficiency in essential tools such as the 

Move Tool, Selection Tools, and Brush Tools for basic image editing.

• Apply Advanced Tools: Effectively use advanced tools like the Pen Tool, 

History Brush Tool, and Dodge Tool for more complex editing tasks.

• Access Menu Functions: Utilize different menu options (File, Edit, Image, 

Layer, etc.) to navigate Photoshop’s features and functionalities.

• Manipulate the Canvas: Gain skills in canvas manipulation with tools like the 

Rotate View Tool and Crop Tool to enhance workflow and composition.

• Create and Edit Paths: Develop the ability to create and manipulate paths 

using the Path Selection Tool and Shape Tools for vector graphics.

• Evaluate and Critique Work: Learn to critically evaluate personal and peer 

work, providing constructive feedback based on Photoshop techniques and 

design principles.
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A Comprehensive Guide to the 

Photoshop Interface and Tools
What is Adobe Photoshop?

Photoshop is a powerful raster graphics editor primarily used for image 

editing, graphic design, and digital art. It is widely recognized as the industry-

standard software for photo manipulation, retouching, and compositing. 

Photoshop enables users to work with layers, filters, brushes, and masks to 

create or enhance images with a high level of precision and creativity.

Common uses of Photoshop include:

• Photo editing and retouching.

• Graphic design for posters, logos, and advertisements.

• Digital painting and illustrations.

• Web design and creating assets for social media.

• 3D modeling and video editing (in some versions).
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A Comprehensive Guide to the 

Photoshop Interface and Tools
Who Made Photoshop?

Photoshop was originally created by Thomas Knoll and John 

Knoll, two brothers, in 1987. Thomas developed the initial version 

as a program to display grayscale images on a monochrome 

display. His brother, John, who was working at Industrial Light & 

Magic, encouraged further development of the software.

In 1988, the Knoll brothers licensed Photoshop to Adobe 

Systems, where it was officially released as Adobe Photoshop 

1.0 in 1990. Since then, Adobe has developed and maintained 

Photoshop, releasing new versions with enhanced features 

regularly.

Today, Photoshop is part of the Adobe Creative Cloud suite of 

applications and continues to evolve, offering users advanced 

capabilities in digital design and image manipulation.
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Home screen

The Welcome to Photoshop window (or Home 

Screen) appears when you launch Photoshop 

and provides quick access to various features 

and resources. It helps users get started quickly 

by offering shortcuts and templates. Here’s 

what the Welcome or Home Screen contains:

1. Recent Files Panel

•Displays thumbnails of your recently opened 

projects for quick access.

•Options to search for recent files or clear the 

recent file list.
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Preset Tabs
At the top of the window, there are different categories of presets:

•Recent: Displays document sizes and settings you've recently 

used.

•Saved: Shows any custom presets you’ve saved for future use.

•Photo: Presets for common photo sizes (e.g., 4x6, 5x7).

•Print: Standard print sizes (e.g., A4, Letter, Legal).

•Web: Presets optimized for web design with specific dimensions 

(e.g., 1920x1080, 1280x720).

•Mobile: Common screen sizes for mobile devices (e.g., iPhone, 

Android).

•Film & Video: Presets for video and film formats, such as 1080p 

or 4K resolutions.
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PHOTOSHOP MENUS

https://gamma.app/?utm_source=made-with-gamma


preencoded.png

The File Menu
The File Menu in Photoshop contains essential commands for file management, 

importing/exporting, printing, and document settings. Here’s an overview of the 

main options available in the File menu:
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The Edit Menu
The Edit Menu in Photoshop provides commands for manipulating content, transforming 

images, adjusting settings, and managing selections. It also contains options for working with 

the clipboard, managing presets, and using some advanced tools like content-aware editing. 
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The Image Menu
The Image Menu in Photoshop provides powerful tools for adjusting and manipulating the overall 

characteristics of an image. This menu allows users to modify image attributes such as color, size, 

rotation, and resolution. Below is an overview of the commands available in the Image Menu:
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The Layer Menu
The Layer Menu in Photoshop is essential for managing layers, which are the building blocks of any 

Photoshop project. Layers allow users to work non-destructively, apply effects, adjust blending 

modes, and control the visibility and stacking order of elements. Here’s an overview of the commands 

available in the Layer Menu:
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The Type Menu
The Type Menu in Photoshop provides tools and options for working with text and typography. 

This menu allows users to create and manipulate text layers, apply various type settings, and 

adjust typography properties. Here’s an overview of the commands available in the Type Menu:
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The Select Menu
The Select Menu in Photoshop is crucial for working with selections, which are used to isolate and 

manipulate specific areas of an image or layer. The commands within this menu allow users to create, 

modify, and refine selections effectively. Here’s an overview of the commands available in the Select 

Menu:
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The Filter Menu
The Filter Menu in Photoshop provides a variety of tools and effects that can be applied to layers or selections to 

enhance images, create artistic effects, or improve the overall appearance of a design. Filters can be applied non-

destructively using Smart Filters or destructively, and they play a crucial role in image editing and creative design. 

Here’s an overview of the commands available in the Filter Menu:
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The Window Menu
The Window Menu in Photoshop provides access to various panels, tools, and workspaces that help users manage 

their workspace and customize the layout according to their workflow preferences. Here’s an overview of the 

commands and options available in the Window Menu:
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The Help Menu
The Help Menu in Photoshop provides users with access to a wealth of resources, including documentation, 

tutorials, and support options. It is designed to assist users in understanding the software, troubleshooting issues, 

and enhancing their skills. Here’s an overview of the commands and options available in the Help Menu:
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PHOTOSHOP TOOLS
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The Move tool
The Move Tool is a fundamental 

tool in Photoshop that allows users 

to reposition layers and selections 

within an image. It enables users to 

click and drag to move entire layers, 

making it easier to arrange elements 

in a composition. The tool also 

includes options for automatic layer 

selection and alignment features, 

enhancing workflow efficiency when 

working with multiple layers. Users 

can create duplicates of layers by 

holding down the Alt key (or Option 

key on Mac) while dragging.
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Rectangular Marquee Tool
The Rectangular Marquee Tool is used for 

making rectangular selections in an image. 

By clicking and dragging on the canvas, 

users can isolate specific areas for editing 

or manipulation. This tool offers various 

selection styles, including fixed ratios and 

sizes, allowing for precise control over the 

selection dimensions. It also supports 

adding to or subtracting from existing 

selections, making it a versatile choice for 

selecting specific portions of an image.
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Elliptical Marquee Tool
The Elliptical Marquee Tool functions 

similarly to the Rectangular Marquee Tool 

but creates elliptical selections instead. 

Users can click and drag to form circles or 

ellipses, allowing for circular or oval-shaped 

selections within an image. Like the 

rectangular version, it supports various 

styles for fixed dimensions, ratios, and 

enables users to refine their selections by 

adding or subtracting from existing ones.

https://gamma.app/?utm_source=made-with-gamma


preencoded.png

Lasso Tool
The Lasso Tool provides a freeform 

selection capability, allowing users to draw 

custom shapes around areas of interest. By 

clicking and dragging, users can create 

complex selections that follow the contours 

of the subject or area they wish to isolate. 

The Lasso Tool is particularly useful for 

selecting irregular shapes, and it includes 

variations such as the Polygonal Lasso 

Tool for straight-edged selections and the 

Magnetic Lasso Tool that automatically 

detects edges in an image.
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Quick Selection Tool
The Quick Selection Tool allows users to 

paint a selection using brush-like strokes, 

making it easier to select subjects with 

complex edges. By clicking and dragging 

over the area to be selected, Photoshop 

automatically expands the selection based 

on color and texture similarities. This tool is 

particularly useful for quickly isolating 

subjects from their backgrounds, and it 

works well in conjunction with the Refine 

Edge tool for further adjustments.
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Magic Wand Tool
The Magic Wand Tool is designed for 

selecting areas of similar color within an 

image. By clicking on a specific color, the 

tool selects all adjacent pixels with similar 

colors, making it easy to isolate 

backgrounds or specific elements. Users 

can adjust the tool’s tolerance level to 

include more or fewer similar colors, 

allowing for greater control over the 

selection process. This tool is most 

effective in images with high color contrast.
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Crop Tool
The Crop Tool enables users to trim and 

adjust the dimensions of an image. By 

dragging the corners of the crop box, users 

can select the area they wish to keep, while 

the rest of the image is discarded. The 

Crop Tool also offers options for setting 

specific aspect ratios and straightening 

images, making it essential for refining 

compositions and improving image framing.
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Frame Tool
The Frame Tool in Photoshop is designed 

to streamline the process of creating 

placeholders for images in layouts, making 

it especially useful for tasks like mockups 

or magazine designs. It allows users to 

easily draw rectangular or elliptical frames 

on the canvas, which can then be filled with 

images that automatically fit within the 

frame's boundaries. Images inside frames 

can be resized and adjusted without 

affecting the frame itself, providing a 

flexible and non-destructive way to work 

with visuals in compositions. This tool 

enhances the layout design workflow, 

simplifying image placement and 

adjustments.
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Eyedropper Tool
The Eyedropper Tool in Photoshop allows 

users to sample and pick up colors from an 

image or canvas. When using the 

Eyedropper Tool, clicking on any area of 

the image captures the color of the pixels 

beneath the cursor, making it the active 

foreground color in the color palette. This 

tool is especially useful for ensuring color 

consistency throughout a design, allowing 

users to match colors precisely from one 

part of the image to another or from an 

external reference. It also offers additional 

settings to sample colors from a specific 

point or an average area, depending on the 

desired accuracy.

https://gamma.app/?utm_source=made-with-gamma


preencoded.png

Spot Healing Brush Tool
The Spot Healing Brush Tool is a 

powerful retouching tool that allows users 

to quickly remove imperfections in an 

image. By painting over blemishes or 

unwanted objects, the tool automatically 

blends the surrounding pixels to seamlessly 

repair the area. It is particularly useful for 

tasks such as removing skin blemishes in 

portrait photography or fixing small 

distractions in a scene.

https://gamma.app/?utm_source=made-with-gamma


preencoded.png

Healing Brush Tool
The Healing Brush Tool is similar to the 

Spot Healing Brush but provides more 

control over the healing process. Users can 

define a source point to sample pixels from, 

allowing them to manually choose the area 

to blend with the imperfections they want to 

correct. This tool is particularly effective for 

more complex retouching tasks where 

precise control over the healing process is 

necessary.
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Brush Tool
The Brush Tool is a versatile painting tool 

that allows users to create custom strokes 

and textures on a canvas. Users can 

choose from a variety of brush shapes, 

sizes, and textures, enabling them to paint 

or draw with precision. The Brush Tool is 

essential for digital painting, retouching, 

and creating artistic effects, allowing for 

extensive creative expression in 

Photoshop.
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Clone Stamp Tool
The Clone Stamp Tool allows users to 

duplicate parts of an image by painting with 

sampled pixels from another area. By 

holding down the Alt key (or Option key on 

Mac) and clicking to define a source point, 

users can then paint over the target area to 

apply the cloned pixels. This tool is 

particularly useful for removing unwanted 

elements or duplicating features within an 

image.
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Eraser Tool
The Eraser Tool is used to remove pixels 

from an image, functioning like a brush but 

in reverse. Users can select different brush 

sizes and hardness levels to control how 

they erase parts of their image. The Eraser 

Tool can also be used to create 

transparency in a layer, making it essential 

for refining compositions and correcting 

mistakes.
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Gradient Tool
The Gradient Tool allows users to create 

smooth transitions between colors in an 

image. By selecting a gradient preset or 

creating a custom gradient, users can apply 

it to a selected area by clicking and 

dragging across the canvas. This tool is 

commonly used for backgrounds, overlays, 

and blending effects, enhancing the visual 

appeal of compositions.

https://gamma.app/?utm_source=made-with-gamma


preencoded.png

Dodge Tool
The Dodge Tool in Photoshop is used to 

lighten specific areas of an image by 

increasing the exposure of the pixels it is 

applied to. It mimics traditional darkroom 

techniques where certain areas of a 

photograph are exposed to more light to 

brighten them. The Dodge Tool is 

commonly used in photo retouching to 

enhance highlights, brighten facial features, 

or bring attention to specific areas of an 

image. Users can adjust the tool’s range 

(shadows, midtones, or highlights) and 

exposure settings to control the intensity of 

the lightening effect, allowing for precise 

and subtle adjustments.
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Pen Tool
The Pen Tool is a precision tool used for 

creating paths and shapes. Users can click 

to create anchor points and control curves 

by adjusting the handles. This tool is 

particularly useful for creating complex 

shapes and selections, as it allows for 

detailed and precise editing. The Pen Tool 

is essential in graphic design for logo 

creation, vector illustrations, and intricate 

selections.
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Path Selection Tool
The Path Selection Tool in Photoshop is 

used for selecting and manipulating entire 

paths created with the Pen Tool or Shape 

Tools. It allows users to click on a path to 

select it and then move, transform, or 

modify it as needed. When a path is 

selected, users can adjust its shape, 

change its fill or stroke properties, and 

apply other transformations. The Path 

Selection Tool is particularly useful in vector 

graphic design and illustration, where 

precise control over paths is essential. It 

helps streamline the workflow by allowing 

users to manage and edit paths efficiently 

within their projects.
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Shape Tools
The Shape Tools consist of several tools 

for creating geometric shapes such as 

rectangles, ellipses, polygons, and custom 

shapes. Users can click and drag on the 

canvas to create shapes, which can be 

filled with color or gradients and modified 

using various options in the Options Bar. 

Shape Tools are valuable for designing 

logos, icons, and other graphic elements.
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Rotate View Tool 
The Rotate View Tool in Photoshop allows 

users to temporarily rotate the canvas to a 

desired angle for more comfortable editing 

and painting. This tool is particularly useful 

for artists and designers who need to work 

on specific details or strokes that may be 

easier to execute at a different angle. Users 

can click and drag on the canvas to rotate it 

freely or use the Options Bar to set a 

specific angle. Importantly, the Rotate View 

Tool does not alter the actual image; it only 

changes the view, allowing for precise 

adjustments without affecting the final 

composition. Users can easily return the 

canvas to its original orientation by 

resetting the view or using the keyboard 

shortcut.
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Workflow Optimization and Productivity Tips

1Automation

Photoshop's automation features, such as Actions and Scripts, 

enable users to streamline repetitive tasks, boost efficiency, 

and unlock new levels of productivity. 2 Keyboard Shortcuts

Mastering Photoshop's extensive keyboard shortcuts can 

significantly improve workflow, allowing users to navigate the 

interface and execute commands with lightning-fast speed.3Interface Customization

Personalized workspace layouts, custom panels, and optimized 

tool sets can be tailored to individual users' preferences, 

enhancing their overall Photoshop experience.
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